mobileterminal

So you upgraded to iOS 4.x and now your MobileTerminal no longer works. It tries to start but immediately dies. This really upsets you as you find that you fairly frequently require it. As a solution you end up with MobileTerminal 426. This comes as a huge relief, that is until you realise that it’s almost unusable. If that sounds like the place you’re currently at then stress not. Comment 61 at http://code.google.com/p/mobileterminal/issues/detail?id=172#makechanges includes a link to a fixed package that works exactly how you’d want MobileTerminal to work, but this time also on iOS 4.x. The comment says:

If Allen would like to get MobileTerminal 426 in Cydia, he should personally contact one of the major repositories, such as BigBoss, to get it hosted. The repository maintainers do not like (nor should they like) working with third parties who are trying to get stuff hosted, as it means that maintenance and other correspondence will be going through someone largely uninvolved. Please: DO NOT submit MobileTerminal to Cydia unless you are Allen Porter.

As for the current MobileTerminal package in Cydia, it is much more functional than revision 426, but does not currently work on iOS 4. What made MobileTerminal useful/interesting was its intricate gesture support, allowing for modifiers like control, special keys like escape, and entire commands to be bound to fast movements on the screen. MobileTerminal 426, meanwhile, doesn’t even support scrolling the terminal screen.

It is therefore incredibly depressing to the core community of users of MobileTerminal that the development has taken the direction it has: users of the existing copy of MobileTerminal simply cannot be upgraded to the “latest” release, as it frankly is an entirely unrelated project. It is my personal opinion that Allen should have renamed this new version of MobileTerminal to something different, like “MobileTerminal Redux” or something, to indicate this.

Due to this confusion, when and if MobileTerminal “426” is released to Cydia, it simply cannot be listed as a direct upgrade to MobileTerminal “364”. When and if this occurs, the current “MobileTerminal” package will be renamed to “MobileTerminal Classic” or something, but retain its package identifier, so existing users can safely continue using it until MobileTerminal manages to regain the functionality that it once had.

Now, it /is/ understood that users of MobileTerminal on iOS 4 currently have issues. However, in the grand scheme of things, not many people were actually using iOS 4 on jailbroken devices until the very recent jailbreakme.com exploit release last week. In order to maintain the current level of functionality for these users, I have been forced (again) to step in and maintain the old (awesome) branch of MobileTerminal. I do not like doing this, and was hoping someone else would step up to the plate, but I will continue to do so until such time as there is a viable replacement. 🙁

Users who wish to help test this new version can obtain it at the following direct .deb URL. It should be noted that this revision isn’t quite right on all devices, having some interesting visual artifacts due to the new way in which it is being rendered. I believe that this can be fixed, but I may end up pushing this release anyway with the old binary also included, doing a selection “is the user on iOS 4? ok, then use XXX binary” when the program is run.

http://apt.saurik.com/debs/mobileterminal_364.3-12_iphoneos-arm.deb

I don’t have to explain how to do anything useful with this, do I? A “dpkg -i” will end up replacing your faulty MobileTerminal with this working one. Happy happy times!! Thank you so much to Saurik for this!!